Navigation issues - 10th Gen Civic Forum
 2Likes
Reply
 
Thread Tools
post #1 of 18 (permalink) Old 07-16-2016, 06:42 AM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 9
Navigation issues

Has anyone else had issues with the navigation? It's seems a lot of times my navigation will locate my position about 10 miles away from where I'm at. The indicator at the top of the screen shows its having issues connecting to satellites, but I've had navigation on other cars and never has this issue before. So basically the the navigation us worthless for about the first 15 minutes then it will start working. Other times I take off and it's fine.
Scoby151 is offline  
post #2 of 18 (permalink) Old 07-18-2016, 08:15 AM
Senior Member
 
Join Date: Jul 2015
Posts: 1,587
Really no idea why your nav system is acting like that. May be best to take it to the dealership. Maybe they can find something even if you can't recreate it in front of them. Or record it on your phone and show it to them if needed.
4Tires is offline  
post #3 of 18 (permalink) Old 07-18-2016, 12:07 PM
Junior Member
 
Join Date: Jan 2016
Posts: 29
Mine works, but not as accurate as Google Maps. It said my location was on the wrong side of the road and about 500 feet past the actual turn i needed to make. Not exactly confidence inspiring.
rex444 likes this.
jlfiii is offline  
 
post #4 of 18 (permalink) Old 07-19-2016, 07:28 PM
Junior Member
 
Desi_NY's Avatar
 
Join Date: Jul 2016
Location: Western New York
Posts: 2
Having issues with the Navi on my 2016 Civic Coupe touring. Have had it to the dealer twice already and I have only had the car for 3 months. The Navi does not seem to know where I am. Often has me off in a field somewhere. Dealership could not replicate the issue the first time I took the car in, so they just reset the system. The navigation system got me lost on the way home from the dealership that evening. The second time he did replicate it, and then they locked the entire display up as they were trying to reset it. The car was in worse shape when I left than before I brought it in. I will be taking the car in on Thursday, and leaving it for a week so they can figure out if it is the satellite receiver on the roof, or if it is the display on the dash. Very frustrating, especially when you pay the extra to get the Navi. In addition to this issue, I also have a third brake light cover assembly falling off. This is my fifth Honda Civic. I love the look of the car, but this is a pain. I never took any of my other four Hondas to the dealership in the 20 years I owned them.
Desi_NY is offline  
post #5 of 18 (permalink) Old 08-04-2016, 02:55 AM
Sam
Junior Member
 
Join Date: Aug 2016
Posts: 10
I've been having the exact same issue with my 1-month old Honda Civic touring. and the Honda service technicians don't have a clue what's causing the problem or how to fix it. Today, one of them told me over the phone they could look at the car for a second time "as a courtesy", but all GPS's are like that and it takes a while for them to link to the satellites. But without a proper satellite link, the system wouldn't be able to start the directions, which is not the case here. The direction start but for a vehicle a few kilometers away.
Sam is offline  
post #6 of 18 (permalink) Old 08-10-2016, 04:29 PM
Junior Member
 
Join Date: Aug 2016
Posts: 1
Navigation - ridiculous

I have similar problems with the navigation. The major issue is that the navigation needs about 5-10 minutes to find the GPS satellites after the engine starts up. Even then, it sometimes shows me about 10-20 feet off the road. Supposedly there was an update in May to fix the problem, but now I get GPS fix closer to 5 minutes than 10.

Ridiculous!
rex444 likes this.
TouringSC is offline  
post #7 of 18 (permalink) Old 08-15-2016, 07:39 AM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 9
Quote:
Originally Posted by Desi_NY View Post
Having issues with the Navi on my 2016 Civic Coupe touring. Have had it to the dealer twice already and I have only had the car for 3 months. The Navi does not seem to know where I am. Often has me off in a field somewhere. Dealership could not replicate the issue the first time I took the car in, so they just reset the system. The navigation system got me lost on the way home from the dealership that evening. The second time he did replicate it, and then they locked the entire display up as they were trying to reset it. The car was in worse shape when I left than before I brought it in. I will be taking the car in on Thursday, and leaving it for a week so they can figure out if it is the satellite receiver on the roof, or if it is the display on the dash. Very frustrating, especially when you pay the extra to get the Navi. In addition to this issue, I also have a third brake light cover assembly falling off. This is my fifth Honda Civic. I love the look of the car, but this is a pain. I never took any of my other four Hondas to the dealership in the 20 years I owned them.
Follow up. I've had my car in the shop for about a month now, so its been there about the same amount of time that I've driven it. The think they have it figured out now, because last time i picked it up I turned around about a mile away and had to take it back because the Nav was doing the same thing. Its frustrating that I traded my 2012 Kia optima in on a car that is basically 5 years new and the Nav doesn't work. My Kia never had an issue with the Nav. And what really gets me is that its not like they just started putting Nav in cars!!! So I dont know why something so buggy would get released!!! I can go pick up a unit under 100 and it works great!! This isn't new technology!!!
Scoby151 is offline  
post #8 of 18 (permalink) Old 08-15-2016, 01:48 PM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 9
After todays appointment and them trying to send me home with a Nav that does not function, they are going to replace the entire unit in the car. I didnt know how to feel about that with a car that has 4000 miles on it.
Scoby151 is offline  
post #9 of 18 (permalink) Old 08-17-2016, 08:13 AM
Senior Member
 
Join Date: Jul 2015
Posts: 1,587
Keep us updated on the nav system replacement. Maybe a few faulty units make their way into the honda civics and the only way to fix it is to replace the unit entirely.
4Tires is offline  
post #10 of 18 (permalink) Old 10-02-2017, 01:37 PM
Junior Member
 
Join Date: Oct 2017
Posts: 1
im having the same problem and am dreading taking it back to the dealer its been in once and had the update of software but is still failing to capture the satalites.. oh by the way the nav antenna is in fact under the dash (near the light sensor).
nigelf is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the 10th Gen Civic Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Camera issues roxybalboa 2016+ Honda Civic Problems And issues 11 11-25-2018 09:23 PM
Navigation Only Available with Leather Interior? BuhBob Electronics, Audio, and Lighting 4 07-15-2016 11:17 PM
Sunroof issues? Pinoy_Grigio 10th Gen Civic General Discussion Forum 22 06-02-2016 01:12 PM
Navigation by Garmin? AlwaysHitVTEC Electronics, Audio, and Lighting 10 03-11-2016 08:16 AM
F/S New 2015 Pioneer AVIC-8100NEX / Kenwood Excelon DNX892 Navigation Patri444 10th Gen Civic General Discussion Forum 0 02-27-2015 06:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome