10th Honda Civic Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hello dear, I just bought New Honda Civic 1.5 Turbo 2016. I'm facing really weird issue, whenever I shoot accelerator for faster pickup there is a sound tick tick like then it goes away after few seconds. Can you please guide me what kind of issue I'm facing? Few people say its a Traction Control issue but I also turned that function off and also drive in S-Mode but didn't resolve. Please help me on this!
 

·
Registered
Joined
·
198 Posts
Hello dear, I just bought New Honda Civic 1.5 Turbo 2016. I'm facing really weird issue, whenever I shoot accelerator for faster pickup there is a sound tick tick like then it goes away after few seconds. Can you please guide me what kind of issue I'm facing? Few people say its a Traction Control issue but I also turned that function off and also drive in S-Mode but didn't resolve. Please help me on this!
On the 9th gen Accord forums I read where even if you disabled the Traction Control, , it would still engage on 2106+ models. There was a certain code you had to enter to get it to actually disable Wonder if maybe Honda is doing that on these civics too.
 

·
Registered
Joined
·
922 Posts
I don't agree that the tick tick is coming from the turbo. That doesn't make sense at all. It has to be from something else.
 

·
Registered
Joined
·
61 Posts
Hello dear, I just bought New Honda Civic 1.5 Turbo 2016. I'm facing really weird issue, whenever I shoot accelerator for faster pickup there is a sound tick tick like then it goes away after few seconds. Can you please guide me what kind of issue I'm facing? Few people say its a Traction Control issue but I also turned that function off and also drive in S-Mode but didn't resolve. Please help me on this!
If you just bought the car and you think something is not right, the dealer should be able to give you an assessment free of charge.
 
1 - 5 of 5 Posts
Top