10th Honda Civic Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Ordered OPT7 HID kit. Nice package.
Mounted ballasts on inside fender well.
Removed old bulbs with a simple twist. Can't get new bulb to seat. Can't get old bulb to seat. Getting frustrated. 100 degrees in the garage. Plus, I just had elbow surgery and my right arm is in a brace. Will try again later.
 

·
Registered
Joined
·
876 Posts
did you check that the mounting points are all flat and you are inserting it correctly? Usually all this stuff is standard industry wide.

if you can take pictures of the contact areas it would go a long way in helping us help you
 

·
Registered
Joined
·
922 Posts
Ah I have that problem all the time.. the more frustrated you get, the more it won't go in. I would wait until it cools off a little bit and try it again man. Hope you get well soon too
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
Invoking Senior Moment Rule. Should have taken a picture of headlight bulb orientation rather than relying on a mental note. I was trying in install bulb 180 degrees out of original orientation. DOH! Installed HIDs without relay harness and didn't work. Will install relay harness and report back.
 

·
Registered
Joined
·
922 Posts
Lol ahh don't you hate when that happens ! But alright.. at least we now know the relay is necessary. Thanks for keeping us updated !
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
In the process of installing relay harness I discovered that the kit I was supplied with is for a straight install, there is no provision to install the relay harness. Called OPT-7 and their mail box in not functional at this time so I had to send an Email. Disappointed to say the least. I will update as to their customer service.
 

·
Registered
Joined
·
922 Posts
Darn.. real sorry this is becoming a hassle.. at least future potential buyers will know what their dealing with if they choose to go with them. I would be pretty upset my darn self
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #8 ·
Watched a U tube video of a HID install without a relay kit. Simple Plug and Play. Reinstalled my kit and both bulbs worked while sitting on radiator support. Thinks changed after I installed bulbs into headlight unit. One side works no matter what I change. Bulbs, ballasts work on one side. I am going to return.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
Called OPT7 yesterday. Phone message says "due to uptick of emails" replies may take some time and phone messaging is still not working. Reply via email as you can't leave a message.
 

·
Registered
Joined
·
182 Posts
Called OPT7 yesterday. Phone message says "due to uptick of emails" replies may take some time and phone messaging is still not working. Reply via email as you can't leave a message.
Sorry for your pain. So frustrating when things should just work !

Maybe they sold a bunch of those kits and peeps are calling to say "what the heck" ?
 

·
Registered
Joined
·
1,587 Posts
I was just reading a few of their amazon reviews and they're not exactly known for their customer service. Hope OPT7 comes through for you.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #14 ·
Got an email from OPT7 with a return postage from USPS. Mailed back my kit and was refunded in 2 days. Nice.
 
1 - 15 of 15 Posts
Top