10th Honda Civic Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I got the Blitz Bullet DC HID kit and have been using it for a few months. I installed it without the relay harness - simple plug and play into the OEM power source. But, when it gets dark outside and the car automatically turns on the low beam lights, the car just dies. Pretty dangerous, so i'm assuming there isn't enough power supplied through the OEM source.

So i'm trying to install them with a relay harness but I can't seem to get it to work. I've connected the positive connection wire to the car fuse box, and negative to the front bumper(ground) - check uploaded pictures. The lights worked perfectly fine without the harness so I know I got the polarity correct as well as all the other connections.

Below is the diagram for the wiring which I followed. Relay harness connects to OEM power source(Driver side). Connect power connection to ballast. Then there's a long connection wire for the passenger side HID light. Connect Positive connection to fuse box (shown in picture), connect negative connection to ground(bumper).

When I switch on low beams, I can hear the relay harness fuse box thing flick on, meaning that it's drawing power but the HID lights don't light up. Which steps did I miss? I've tried connecting the positive connection to the red positive terminal(top left in the picture) but that didn't work at all. No flicking sound coming from relay harness when I switch on low beams.
 

Attachments

1 - 1 of 1 Posts
Top