10th Honda Civic Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Hi guys, I foolishly installed an old Voltage Stabilizer from my old car to my Honda Civic 1.8 and the engine is not a bit rough when driving. When rough I mean it feels like the engine jerks a little when driving - like using a higher Ron fuel than recommended. This feeling is less noticeable when the Eco mode is switched on. I took out the VS the next day itself but the engine is still not as smooth as before.

At one point today I was driving on the highway at 90kmph and on a slightly bumpy road. The car felt like it was an F1 car jumping around while cornering at high speed. That being said, nothing feels wrong with the car - RPM seems at normal range, fuel consumption normal...

Wondering if you guys could help...I fear the VS could've messed up with some of the electronics in the engine management system. Is it possible to re-tune the engine to some kinda default settings? What should I do now? It was running so smoothly before this though a little underpowered :|
 

·
Registered
Joined
·
922 Posts
The stabilizer wouldn't interrupt or disturb anything with the ecm. It's essentially just a capacitor that's in line with the battery and everything else to ensure no spikes or dips occur.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
then what is this I'm feeling? The vibrations when going on some roads (that I've been before) were never there previously. Plus the revs have been a little inconsistent when driving rather than holding stable at...let's say 2k/rpm
 
1 - 3 of 3 Posts
Top